Hamachi Installation unter Ubuntu 7.10 Gutsy

Hamachi Logo

Wie ich in den Updates 2 und 3 meines Artikels zur Installation von Hamachi unter Linux geschrieben hab, gibt es Probleme mit der Installation von Hamachi unter Ubuntu 7.10 (Gutsy). Nun hab ich eine Lösung für dieses Problem gefunden und möchte diese natürlich auch euch offenlegen. Aus einem mir unbekannten Grund scheint Gutsy Probleme zu haben die mit UPX gepackte ausführbare Datei /usr/bin/hamachi auszuführen. Um dieses Problem zu umgehen muss diese gepackte Datei einfach entpackt werden.
Dafür muss zur Vorbereitung das Paket “upx-ucl-beta” (Oder wenn verfügbar “upx-ucl”) installiert werden. Dies kann grafisch z.B. mit Synaptic oder direkt in einem Terminal passieren:

sudo apt-get install upx-ucl-beta

Nun wird mittels der neuen Anwendung “upx” die Datei /usr/bin/hamachi entpackt. Dazu reicht der folgende Befehl im Terminal:

cd /usr/bin; sudo upx -d hamachi

Anschließend sollte die Installation problemlos weiter verlaufen also hamachi, hamachi-init & co sollten sich ausführen lassen.

Die Anleitung zur Installation von Hamachi unter Linux wurde entsprechend für Ubuntu 7.10 (Gutsy) angepasst.


  • Pingback: Hamachi Linux-Einrichtung at Blog.Jbbr.net()

  • virusmoere

    hey =)

    thx for that :)

  • Fred

    Juhu vielen Dank, hat sofort funktioniert!

  • Me

    THX darauf wäre ich nie gekommen.

  • neo

    hi. ich habe probleme mit dieser installation. 1. die datei hamachi-ini fehlt. 2. die befehle checkinstall und make install existieren nicht. ich nutz kubuntu 6.15. weiss jemand eine lösung?

  • http://php4you.de foxx

    Hi,

    du musst für checkinstall das Paket “checkinstall” und für make das Paket “make” installieren. Wenn du alle wichtigen Pakete zum Übersetzen von Quellcode benötigst kannst du auch das Paket “build-essential” installieren. Da ist auch make dabei.

    Gruß,
    foxx

  • Flex

    Kann man in der Linux Version von Hamachi einen Proxy eintragen, mein Problem ist das ich hinter einem http Proxy sitze mit der Windows Version geht dies.

  • http://openid.jbbr.net/foxx foxx

    Hm nicht das ich wüsste… aber du kannst ja mal im Hamachi Forum fragen bzw suchen:

    https://forums.hamachi.cc/viewforum.php?f=15

    was ich grad gefunden habe:
    https://forums.hamachi.cc/viewtopic.php?t=18733 (Keine Lösung, selbe Frage für OSX)