Pakete

Hier betreibe ich eine kleine private Paketquelle mit Ubuntu Paketen. Sie ist immer nur für die aktuelle Ubuntu Version zugänglich also im Moment Ubuntu 7.10 (Gutsy). Die meisten Pakete sind als i386 (32bit) und amd64 (64bit) verfügbar. Einige wenige gibt es nur als 32bit Version. Hinzufügen lässt sich das Repositorium durch folgende Eingabe in ein Terminal (ALT-F2 / „gnome-terminal“ oder Anwendungen/Zubehör/Terminal):

Für Ubuntu 7.10 (Gutsy Gibbon)

sudo wget http://ubuntu.jbbr.net/gutsy.list -O /etc/apt/sources.list.d/jbbr.list

Für Ubuntu 8.04 (Hardy Heron)

sudo wget http://ubuntu.jbbr.net/hardy.list -O /etc/apt/sources.list.d/jbbr.list

Für alle Ubuntu Versionen

Um noch den GPG Key des Repositorys einzufügen und so keine „Nicht Authentifiziert“ Meldungen mehr zu bekommen und nach neuen Paketen zu suchen reicht die folgende Eingabe:

wget -q http://ubuntu.jbbr.net/jbbr_ubuntu.asc -O- | sudo apt-key add - && sudo apt-get update

Dies gilt für alle Versionen. Alternativ können die einzelnen Pakete auch manuell aus der unten stehenden Liste geladen werden. Dabei muss in der Download-Spalte die entsprechende Architektur ausgewählt werden. In der Regel ist dies i386 (32 Bit System) und manchmal amd64 (64 Bit System). „all“ steht für ein Plattformunabhängiges Paket, welches für i386, amd64 und weitere verwendet werden kann. Wenn es einen Zusatz „data“ gibt dann muss das „data“-Paket als erstes installiert werden und danach das Hauptpaket. Außerdem gibt es noch einen grünen Button hinter jedem Paket zur Installation.

Hinweis: Der INSTALL-Link zur Installation der Pakete funktioniert nur, wenn die oben angegebene Paketquelle eingebunden wurde und ein Paket mit diesem Namen noch nicht installiert wurde. Ein Update des Paketes über das Bild ist nicht möglich!

Ich übernehme keine Haftung für eventuelle Schäden die durch meine Pakete auftreten könnten. Da ich die Pakete jedoch auch selber verwende und teste sind diese unwarscheinlich. Dennoch sollten diese Pakete nicht als sehr stabil betrachtet werden.

Bitte im Launchpad Bugs melden und fragen stellen: Zum Jbbr Packaging Projekt im Launchpad

Paketliste (Alle Pakete; wird automatisch regelmäßig generiert):
http://ubuntu.jbbr.net/

Ubuntu 8.04 Hardy – Paketliste (Auswahl, Eventuell nicht immer aktuell)

NameVersionDownloadHomepage
conduit0.3.9allHomepageINSTALL
devede3.8allHomepageINSTALL
filezilla3.0.10i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
gparted0.3.6i386, amd64HomepageINSTALL
kraft0.25i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
pcmanfm (PCMan File Manager)0.4.0i386, amd64HomepageINSTALL

Ubuntu 7.10 Gutsy – Paketliste (Auswahl, Eventuell nicht immer aktuell)

NameVersionDownloadHomepage
asunder1.0.2i386, amd64HomepageINSTALL
avidemux2.4.1i386, amd64HomepageINSTALL
blueproximility1.2.4allHomepageINSTALL
brasero0.7.1i386, amd64HomepageINSTALL
cheese2.21.5i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
conduit0.3.8allHomepageINSTALL
cryptkeeper0.9.1i386, amd64HomepageINSTALL
DeVeDe3.6allHomepageINSTALL
Drapes0.5.2allHomepageINSTALL
dvgrab3.1i386, amd64HomepageINSTALL
Easy Funktion6.03ai386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
Easytag2.1.5 (unstable)i386, amd64HomepageINSTALL
filezilla3.0.8i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
gimp2.4.5i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
gnomad22.9.1i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
gnormalize0.53allHomepageINSTALL
gnomevfs2.20.1i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
gnubversion0.5i386, amd64HomepageINSTALL
gpodder0.11.0allHomepageINSTALL
graphmonkey1.7allHomepageINSTALL
isomaster1.3.1i386, amd64HomepageINSTALL
kino1.3.0i386, amd64HomepageINSTALL
kraft0.25i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
ctemplate (von kraft benötigt)0.9i386, amd64HomepageINSTALL
libburn0.4.2i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
libmtp0.2.6.1i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
libtheora1.0 beta2i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
linphone2.1.1i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
lm-sensors2.10.5i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
medit0.9.3i386, amd64HomepageINSTALL
movic0.1.0i386, amd64HomepageINSTALL
mtpfs0.8+svn11i386, amd64HomepageINSTALL
nautilus-image-converter0.2.1i386, amd64HomepageINSTALL
nvclock (CLI, GTK, QT)0.8b3i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
ogmrip0.11.2i386, amd64HomepageINSTALL
parcellite0.6.1i386, amd64HomepageINSTALL
pcmanfm (PCMan File Manager)0.3.6.2i386, amd64HomepageINSTALL
pybackpack0.5.4allHomepageINSTALL
rhythmbox0.11.5i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
sensors-applet2.2.1i386, amd64HomepageINSTALL
svicoder0.7.1allHomepageINSTALL
soundconverter0.9.8allHomepageINSTALL
tangerine0.3.0i386, amd64HomepageINSTALL
tennix0.5.0i386, amd64HomepageINSTALL
tomboy0.10i386, amd64HomepageINSTALL
totem-pl-parser2.21.6i386, amd64
(Bitte Repo nutzen)
HomepageINSTALL
wifi-radar1.9.8allHomepageINSTALL
winki (Winki The Ripper)0.4.5all (data), allHomepageINSTALL
  • Gero

    Erstmal besten Dank für die Pakete, die meinen Zen zum laufen gebracht haben. Aber seit ich die Paketquellen eingebunden hab will Ubuntu ständig libgstreamer updaten. Und zwar von 0.10.15-2~jbbr1 auf 0.10.15-2~jbbr1… irgendeine Ahnung was das Problem ist?

  • Hallo,

    danke für die Info ich habe sie selbst bemerkt und bin selber ziemlich verwundert. Dies sollte „theoretisch“ nicht passieren können besonders da es ja scheinbar kein lokales Problem zu sein scheint sondern wirklich mit dem Paket zusammenhängt da es ja nicht nur bei mir passiert.

    Ich habe bereits verschiedene Leute im IRC gefragt und in verschiedenen Foren einen Thread aufgemacht. Niemand scheint eine Lösung zu kennen aber ich weiß, dass ein solches Problem schon einmal bei einem offiziellen Repository aufgetreten ist und irgendwann gelöst wurde…

    Ich bitte darum das Problem erst einmal zu entschuldigen ich hoffe ich finde in den nächsten Tagen eine Lösung und ich schreib jetzt auch einmal einen Blog Eintrag dazu. Am besten einfach das Update ignorieren oder einfach zusammen mit anderen Updates ausführen. Es wird nicht jedes Mal noch einmal runter geladen sondern wird aus dem Apt Cache geladen also verbraucht es kein Traffic.

    Ich empfehle NICHT das Paket z.B. in Synaptic zu „sperren“, also keine Updates zuzulassen, da ihr dann keine Updates mehr bekommt falls ich das Problem gelöst haben sollte oder es eine komplett neue Version gibt.

    Gruß,
    Janek

  • @Gero und auch @all:
    Es gibt nun eine neue Paketquellenadresse und im neuen Repository hab ich das Problem lösen können. Es tritt auch nur auf, wenn das Repository nicht signiert ist, was bei den PPA Repositorys leider der Fall ist.

  • Herbert

    Beim Versuch Winki unter gutsy zu installieren, fehlt PALDUMP.
    Any hints, wo ich das herbekomme? Thx

  • Danke für den Hinweis, ich prüfe das gleich mal mit einem Standard Ubuntu. Normalerweise sollten die Pakete alle ohne zusätzliche Abhängigkeiten funktionieren und wenn solche benötigt werden pack ich die in der Regel alle ins Repository. Vielleicht hab ich da bei einem Update der Version nicht gesehen, dass es neue Abhängigkeiten gibt die ich lokal beim Test schon installiert hatte.

    Ich meld mich wenn ich das behoben hab.

    Gruß,
    foxx

  • Okay, in wenigen Minuten wird paldump im Repository verfügbar sein. Dauert einen Moment bis es auf beiden Mirrorn liegt. Ich hoffe damit sollte das Problem gelöst sein.

    PS: Eine amd64 Version folgt nachher.

    Gruß,
    foxx

    EDIT: amd64 Version ist nun auch online.

  • nemoinis

    Hi, could you please update totem-plparser in your gutsy packages? the version you have has a bug that breaks podcast handling (see http://bugs.archlinux.org/task/9487 ). Thanks!

  • Hi nemoinis. Thank you for you report. Could you please test the 2.21.91 builds I made? Currently I have no running gutsy on my computer.
    They are available on http://ppa.launchpad.net/jbbr/ubuntu/pool/main/t/totem-pl-parser/ . If you have a Launchpad account please answer on https://bugs.launchpad.net/jbbr/+bug/235578

  • Izual

    Kommt noch eine Version für Ubuntu 8.10? Oder kann man da einfach die 8.04 nehmen? (Wegen eventuellen neuen Programm Versionen?)

  • @Izual: schau dir mal https://blog.jbbr.net/2008/08/21/wo-bleiben-die-paket-updates/ an. Also derzeit arbeite ich eh unter Mac und hab auch sonst nicht viel Zeit neue Pakete zu bauen. Die 8.04 Pakete werden großteils auch mit 8.10 laufen, jedoch sind unter 8.10 vermutlich eh fast alle Pakete bereits auf dem Stand dieses Repositorys.
    Wenn du Ahnung, Zeit und Lust hast kannst du gerne neue Pakete bauen. Die Ressourcen stelle ich gerne zur Verfügung 😉

  • Pingback: Repository nun auch für Hardy | Blog.Jbbr.net()